Error 180 - Failed to retrieve configuration from server
This article contains troubleshooting information
Source-Connect #180: Failed to retrieve configuration from server. Please check your internet connection or click on Help for further information on how to resolve this issue.
Source-Connect | 3.9 | macOS
Description
When users try to log in, they receive an error message saying "Failed to retrieve configuration from server".
Cause
There are three different known causes of Error 180, (and the closely related Error 124). Please read the following sections carefully to determine which issue is most likely to be causing your problem.
- Network or Firewall issues preventing Source Connect from reaching the server. This can be common on business or enterprise networks that haven’t been set up correctly, or where antivirus or VPN software is used.
- The issue is due to an Expired Auth Certificate, and occurs on some older Mac Operating Systems (macOS 10.10 and older) following an API update in September 2020.
- On rare occasions, this error might be caused by an outage. To verify if that is the cause, navigate to https://dashboard.source-elements.com/. If the website works, there is no outage.
- If you have logged out and back into your account and the issue still persists, please check that your IP address is listed as the default.
Actions
Determining the cause is a process of elimination.
Cause 1 - Network or Firewall issue
If you are on a modern Mac Operating System, Cause 1 is the most likely. To troubleshoot cause one - Network and firewall issues:
- Consult your network administrator if you are on a business or enterprise network or have complex network security (check out our Network Guides article for IT and API information).
- Check if the there is an AVID ethernet controller plugged into the computer. These often use the same ports (6000 and 6001) as Source-Connect. Usually, setting up two different ports in the router for the computer (for example, 7000 and 7001) and setting Source-Connect Pro to use those instead solves the issue. This applies to macOS 10.10 and lower.
- Disable any Anti-Virus tools you may be running, or local firewall applications: at least for testing.
- It is crucial for Source-Connect and Source-Live to have the first Ethernet port as the priority port for the Internet connection, and not down the list after Econ/ Bluetooth, or others.
- Make sure you are NOT on VPN.
In addition, if you are using a 5G hotspot and getting the 180 error message, but you don't see it with other connection types, the problem might be related to Source-Connect not supporting IPv6.
- For Macs, execute the following service in a terminal: networksetup -setv6off Wi-Fi. Then, restart Source-Connect. You can find more information on how to disable IPV6 on your Mac here: https://vladtalks.tech/vpn/how-to-disable-ipv6-on-mac#disable-ipv6-from-the-command-line
- For Windows, follow the steps details in this article: https://answers.uillinois.edu/uis/page.php?id=99981
Cause 2 - Expired Auth Certificate
If you are on an older Mac operating, system cause 2 is most likely.
- Try creating a new administrator account on your computer and running Source Connect from there. If this works, you can safely assume an expired Security Certificate was likely the cause.
- There are three known solutions, each with their own pro’s and cons:
i. Update to a newer Operating System.
ii. Delete your Keychain (Quick fix but you lose passwords).
iii. Run everything from the new Admin account in your computer (often only a temporary solution).
Delete your Keychain Quick Fix - Warning!
The "QUICK FIX" is to delete the old User Keychain. The keychain is a document on the hard drive that has the list of passwords and Auth certificates.
NOTE: the danger is this Keychain ALSO contains automatic log in passwords for websites and apps, so you should be aware that you will lose ALL your automatic logins for websites and apps.
Cause 3 - Outage
Email support@source-elements.com and write Urgent in the subject heading. This is rare but if it happens we want to know about it and be able to update everyone who is effected once we have resolved it so emailing us helps us achieve this.
If there are any other causes we also want to know about them so we can keep people informed. So if you’re not sure, send us an email anyway and we’ll help you troubleshoot.
Cause 4 - Check if your IP is listed as default
You will need to be able to log into Source-Connect to perform these steps.
In Source-Connect Pro, you can select this manually:
For Source-Connect Standard, go to System Preferences > Network > Advanced. Then, go to the TCP/IP tab. Your IP address will appear next to the IPv4 address label.