Error 181 - No valid audio device found
This article contains troubleshooting information
Source-Connect #181: No valid audio device found. Please ensure you have a valid audio device available. Please click on Help for further information on how to resolve this issue.
Source-Connect | 3.X | macOS
Description
When users try to open the application, they receive the following error message:
Causes
Source-Connect is usually not able to detect valid audio hardware due to one of the following issues:
- There is no audio hardware installed on the computer.
- A Virtual Driver is causing the problem.
- Your operating system has not given permissions to Source-Connect to use the audio hardware.
Actions
- Check that Source-Connect has permissions to access the microphone. If so, proceed through this list. If not, skip ahead to Resolving Permissions Issues below.
- Make sure there is a valid audio device select for input and output on your system.
- If there is no audio device, then be sure to either connect external audio hardware, or install a Source Elements virtual audio device such as Source-Nexus I/O (macOS only). Download Source-Nexus I/O free audio driver (macOS only).
- Try to remove any 3rd party virtual drivers and add them back one at a time in order to see if any of them are causing the problem.
- Big Sur users - as a last resort, try upgrading to Monterey. Keep in mind some Source-Connect features will not work in Monterey. We recommend contacting the support team beforehand.
Resolving Permission Issues on macOS
If Source Connect is not showing at all in the Microphone Permissions window in System Preferences > Security and Privacy > Privacy > Microphone, then this is a permission issue.
In that case, try running the following terminal command: tccutil reset All. This resets all permissions, so your computer will ask you for permission each time a program needs to access something. If this has worked for Source-Connect, then when you open the program you should get a pop-up asking for Source Connect to be allowed access to your microphone.
If this does not work you can try the following:
1. Run the application from a sudo command in terminal. In terminal, manually enter the path: sudo “\file path from hard drive to application.app/Contents/MacOS/application name, or try typing ‘sudo’, and dragging the described .app (in the Contents/MacOS/ folder) after it.
2. Press enter, and enter the system password. This should open the Source-Connect application bypassing the permissions that were blocking it.
You should get a pop-up asking you to give Terminal permission to access the microphone, click ‘allow’ and you should be able to use Source Connect in this way.
You can make a script as an ‘opening shortcut’ for later use. In order to do so:
- Go to TextEdit. Create a new document.
- In the top bar go to format -> make plain text.
- Type: sudo /Applications/Source-Connect\ Pro.app/Contents/MacOS/Source-Connect\ Pro . Adjust this path/filename as appropriate for the program.
- Save as: SourceConnectOpen.command (or any other name).
You can now double click this, and it will run the command in Terminal, and should open Source Connect Pro.
If you get a permissions error trying to open the new file you created, but the permissions are showing correctly under the ‘get info’ panel, then go to terminal and enter:
chmod u=rwx,g=rwx,o=rwx [file_name]
For [file_name], you can drag and drop the text file into the terminal.
This will update the file permissions, and you should then be able to use the file to open Source-Connect via terminal.
Still having trouble? Contact our Support team
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